Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

opensesame not working in ubuntu 16.10 (yakkety)

edited October 2016 in OpenSesame

Hello! I have installed OpenSesame from the ppa (smathot/cogscinl/ubuntu) for yakkety and run into the following problem when I try to launch:

$ opensesame
Traceback (most recent call last):
  File "/usr/bin/opensesame", line 25, in <module>
    __main__.opensesame()
  File "/usr/lib/python2.7/dist-packages/libqtopensesame/__main__.py", line 105, in opensesame
    opensesame.resume_init()
  File "/usr/lib/python2.7/dist-packages/libqtopensesame/qtopensesame.py", line 105, in resume_init
    from QProgEdit import validate
  File "/usr/lib/python2.7/dist-packages/QProgEdit/__init__.py", line 69, in <module>
    from QProgEdit._quiloader import QUiLoader
  File "/usr/lib/python2.7/dist-packages/QProgEdit/_quiloader.py", line 23, in <module>
    from QProgEdit.pyqt5compat import uic
  File "/usr/lib/python2.7/dist-packages/QProgEdit/pyqt5compat.py", line 22, in <module>
    from PyQt5 import Qsci
ImportError: cannot import name Qsci

I've checked and python-pyqt5 python-qscintilla2 and related packages are installed and up to date. Is this maybe a known problem on ubuntu 16.10? I notice that this clean (supposedly fine) installation of 16.10 that there are no shared object files for a Qt5 version of Qsci anywhere in /usr:

find /usr -type f | grep Qsci
./share/opensesame_resources/android/PyQt4/Qsci.py
./lib/python2.7/dist-packages/PyQt4/Qsci.x86_64-linux-gnu.so
./lib/python2.7/dist-packages/PyQt4/Qsci.pyi

Has anyone gotten OpenSesame working on Ubuntu 16.10? Thanks for any help.

Kevin

Comments

  • Hi Kevin,

    What happens is the following: OpenSesame installs all the correct PyQt4 dependencies, but picks PyQt5 if it is available. On your system it is, only it doesn't have QScintilla installed--you only have the PyQt4 version of QScintilla. So you need to install also python-pyqt5.qsci, and perhaps also other pyqt5 components if OpenSesame still doesn't work (check the error messages for which ones).

    Cheers!
    Sebastiaan

    Buy Me A Coffee

  • thank you! I'm sorry I pestered you instead of figuring out that I just needed this package.

  • I have the same issue. Have done

    sudo apt-get install python3-pip
    pip3 install QScintilla
    

    but still get

    $ opensesame
    Traceback (most recent call last):
      File "/usr/bin/opensesame", line 25, in <module>
        __main__.opensesame()
      File "/usr/lib/python2.7/dist-packages/libqtopensesame/__main__.py", line 83, in opensesame
        opensesame.resume_init()
      File "/usr/lib/python2.7/dist-packages/libqtopensesame/qtopensesame.py", line 105, in resume_init
        from QProgEdit import validate
      File "/usr/lib/python2.7/dist-packages/QProgEdit/__init__.py", line 69, in <module>
        from QProgEdit._quiloader import QUiLoader
      File "/usr/lib/python2.7/dist-packages/QProgEdit/_quiloader.py", line 23, in <module>
        from QProgEdit.pyqt5compat import uic
      File "/usr/lib/python2.7/dist-packages/QProgEdit/pyqt5compat.py", line 22, in <module>
        from PyQt5 import Qsci
    ImportError: cannot import name Qsci
    

    Any ideas?

    $ opensesame --version
       3.1.4b1 'Jazzy James'
    
  • @earcanal Python 2 and 3 are completely separate environments. pip3 installs packages for Python 3, pip for Python 2. So you've installed QScintilla for Python 3, whereas OpenSesame uses Python 2, as you can tell from the stacktrace.

    Pro-tip: In Ubuntu, most Python packages are available through the repositories (like QScintilla) or external PPAs (like OpenSesame). Whenever possible, I would use those instead of pip.

    Buy Me A Coffee

  • Can you tell from the above errors which packages I need to install? I seem to already have what I thought was QScintilla for Python 2:

    $ sudo apt-get install python-qscintilla2
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    python-qscintilla2 is already the newest version (2.9.1+dfsg-4build1).
    0 to upgrade, 0 to newly install, 0 to remove and 6 not to upgrade.
    
  • Can you tell from the above errors which packages I need to install? I seem to already have what I thought was QScintilla for Python 2:

    See my first reply!

    Buy Me A Coffee

  • Sorry, python-pyqt5.qsci didn't look like a package name, so I thought resolving this was harder than it looked! To be clear, the only thing I needed to do was

    sudo apt-get install python-pyqt5.qsci
    

    Thanks for bearing with me ;-)

  • hahhah
    edited July 29

    Hi I'm stuck in the same issue on Ubuntu 18 LTS

    I'm unable to install python-pyqt5.qsci

    The error is

    `E: Unable to locate package python-pyqt5.qsci`


    The debug windows shows the error:

    `ImportError: cannot import name 'Qsci' from 'PyQt5'`

    and OpenSesame doesn't start


    I have installed QScintilla using pip3.

Sign In or Register to comment.

agen judi bola , sportbook, casino, togel, number game, singapore, tangkas, basket, slot, poker, dominoqq, agen bola. Semua permainan bisa dimainkan hanya dengan 1 ID. minimal deposit 50.000 ,- bonus cashback hingga 10% , diskon togel hingga 66% bisa bermain di android dan IOS kapanpun dan dimana pun. poker , bandarq , aduq, domino qq , dominobet. Semua permainan bisa dimainkan hanya dengan 1 ID. minimal deposit 10.000 ,- bonus turnover 0.5% dan bonus referral 20%. Bonus - bonus yang dihadirkan bisa terbilang cukup tinggi dan memuaskan, anda hanya perlu memasang pada situs yang memberikan bursa pasaran terbaik yaitu http://45.77.173.118/ Bola168. Situs penyedia segala jenis permainan poker online kini semakin banyak ditemukan di Internet, salah satunya TahunQQ merupakan situs Agen Judi Domino66 Dan BandarQ Terpercaya yang mampu memberikan banyak provit bagi bettornya. Permainan Yang Di Sediakan Dewi365 Juga sangat banyak Dan menarik dan Peluang untuk memenangkan Taruhan Judi online ini juga sangat mudah . Mainkan Segera Taruhan Sportbook anda bersama Agen Judi Bola Bersama Dewi365 Kemenangan Anda Berapa pun akan Terbayarkan. Tersedia 9 macam permainan seru yang bisa kamu mainkan hanya di dalam 1 ID saja. Permainan seru yang tersedia seperti Poker, Domino QQ Dan juga BandarQ Online. Semuanya tersedia lengkap hanya di ABGQQ. Situs ABGQQ sangat mudah dimenangkan, kamu juga akan mendapatkan mega bonus dan setiap pemain berhak mendapatkan cashback mingguan. ABGQQ juga telah diakui sebagai Bandar Domino Online yang menjamin sistem FAIR PLAY disetiap permainan yang bisa dimainkan dengan deposit minimal hanya Rp.25.000. DEWI365 adalah Bandar Judi Bola Terpercaya & resmi dan terpercaya di indonesia. Situs judi bola ini menyediakan fasilitas bagi anda untuk dapat bermain memainkan permainan judi bola. Didalam situs ini memiliki berbagai permainan taruhan bola terlengkap seperti Sbobet, yang membuat DEWI365 menjadi situs judi bola terbaik dan terpercaya di Indonesia. Tentunya sebagai situs yang bertugas sebagai Bandar Poker Online pastinya akan berusaha untuk menjaga semua informasi dan keamanan yang terdapat di POKERQQ13. Kotakqq adalah situs Judi Poker Online Terpercayayang menyediakan 9 jenis permainan sakong online, dominoqq, domino99, bandarq, bandar ceme, aduq, poker online, bandar poker, balak66, perang baccarat, dan capsa susun. Dengan minimal deposit withdraw 15.000 Anda sudah bisa memainkan semua permaina pkv games di situs kami. Jackpot besar,Win rate tinggi, Fair play, PKV Games