Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

experiment runs differently on external browser

hello all

PLEASE HELP! my experiment runs fine on open sesame(the app). but as soon as i run it on OSweb on google chrome, some of the contents do not show (attached is

a "feedback" slide that doesnt show on OSweb, but shows when the experiment is run from the app) also my keyboard commands dont seem to work on OSweb.

i dont know if this info is relevant, but when i open OSweb on google it says that my OSweb version is 1.3.0

What can i do to fix this? so that my feedback slide shows on OSweb and my keyboard commands work?

thank you in advance

sincerely

ruby


Comments

  • Hi Ruby,

    Without more information it's difficult to say. Could you post the experiment here, and describe in more detail what exactly doesn't work on OSWeb?

    Cheers!

    Sebastiaan

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • hi Sebastiaan

    thanks so much for the reply and sorry for the late reply.

    the experiment doesn't even let me attach it here. it says error code 400...:(

    but basically what happened is that, the experiment runs perfectly fine in my opensesame app (version 3.2.7) but when i run it "in an external browser (under OSweb)" the experiment doesnt run after the first few slides.

    i'm thinking maybe it has something to do with the experiment being created using a much older version of opensesame (the experiment is not my own, i'm just using it). if this is the case, how can i fix it?

    by the way i have changed all the older features to the new opensesame compatible alternatives (such as text-display).

    i'm still trying to upload the experiment here. i'm trying uninstalling opensesame and re installing it again.

    thanks in advance!

    ruby

  • i hope this is relevant, this is where i downloaded the experiment, on the open science framework.

    https://osf.io/jgrx9/

  • hi Sebastiaan

    i re installed opensesame, still doesn't let me attach the experiment here (error code 400). i also tried screen recording, however the forum does not allow the video format.

    also, the link i sent in the previous comment contains multiple experiments of a whole program, not just 1 experiment. but the same problem (of running normally in the app, but not running after the first few slides in OSweb) exists in all the experiments.

    i hope my descriptions are clear enough for you to please find out what caused the problem and how to solve it...๐Ÿ˜… tried my best story telling skills ๐Ÿ˜‚

    thanks in advance

    ruby

  • Hi Ruby,

    OSWeb supports only a subset of all the functionality that is supported by OpenSesame on the desktop. So your experiment probably uses items that simply aren't supported. You can find an overview of supported functionality here:

    Also, if you go to Menu → Tools → OSWeb, you will get a quick (and not full-proof) compatibility check to see if your experiment will run in a browser.

    Cheers!

    Sebastiaan

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • thank you!!

Sign In or Register to comment.